OSEC

Neohapsis is currently accepting applications for employment. For more information, please visit our website www.neohapsis.com or email hr@neohapsis.com
 
[ GLSA 200405-07 ] Exim verify=header_syntax buffer overflow

From: Thierry Carrez (koongentoo.org)
Date: Fri May 14 2004 - 14:29:55 CDT


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200405-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: Exim verify=header_syntax buffer overflow
      Date: May 14, 2004
      Bugs: #50217
        ID: 200405-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

When the verify=header_syntax option is set, there is a buffer overflow
in Exim that allows remote execution of arbitrary code.

Background
==========

Exim is an highly configurable message transfer agent (MTA) developed
at the University of Cambridge.

Affected packages
=================

    -------------------------------------------------------------------
     Package / Vulnerable / Unaffected
    -------------------------------------------------------------------
  1 net-mail/exim <= 4.33 >= 4.33-r1

Description
===========

When the option "verify = header_syntax" is used in an ACL in the
configuration file, Exim is vulnerable to a buffer overflow attack that
can be triggered remotely by sending malicious headers in an email
message. Note that this option is not enabled in Exim's default
configuration file.

Impact
======

This vulnerability can be exploited to trigger a denial of service
attack and potentially execute arbitrary code with the rights of the
user used by the Exim daemon (by default this is the "mail" user in
Gentoo Linux).

Workaround
==========

Make sure the verify=header_syntax option is not used in your exim.conf
file.

Resolution
==========

All users of Exim should upgrade to the latest stable version:

    # emerge sync

    # emerge -pv ">=net-mail/exim-4.33-r1"
    # emerge ">=net-mail/exim-4.33-r1"

References
==========

  [ 1 ] CAN-2004-0400
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0400

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

     http://security.gentoo.org/glsa/glsa-200405-07.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
securitygentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Technologies, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFApR4zvcL1obalX08RAj4qAKCImDLrj24oLDw0LWp9GjS3dxeHpQCglZvQ
fQIUyrGQF9T14nRKUWCceS4=
=T3cu
-----END PGP SIGNATURE-----