OSEC

Neohapsis is currently accepting applications for employment. For more information, please visit our website www.neohapsis.com or email hr@neohapsis.com
[ GLSA 200903-39 ] pam_krb5: Privilege escalation

From: Pierre-Yves Rofes (pygentoo.org)
Date: Wed Mar 25 2009 - 17:45:17 CDT


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200903-39
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: pam_krb5: Privilege escalation
      Date: March 25, 2009
      Bugs: #257075
        ID: 200903-39

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Two vulnerabilities in pam_krb5 might allow local users to elevate
their privileges or overwrite arbitrary files.

Background
==========

pam_krb5 is a a Kerberos v5 PAM module.

Affected packages
=================

    -------------------------------------------------------------------
     Package / Vulnerable / Unaffected
    -------------------------------------------------------------------
  1 sys-auth/pam_krb5 < 3.12 >= 3.12

Description
===========

The following vulnerabilities were discovered:

* pam_krb5 does not properly initialize the Kerberos libraries for
  setuid use (CVE-2009-0360).

* Derek Chan reported that calls to pam_setcred() are not properly
  handled when running setuid (CVE-2009-0361).

Impact
======

A local attacker could set an environment variable to point to a
specially crafted Kerberos configuration file and launch a PAM-based
setuid application to elevate privileges, or change ownership and
overwrite arbitrary files.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All pam_krb5 users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=sys-auth/pam_krb5-3.12"

References
==========

  [ 1 ] CVE-2009-0360
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-0360
  [ 2 ] CVE-2009-0361
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-0361

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200903-39.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
securitygentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2009 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAknKs/0ACgkQuhJ+ozIKI5jOHwCaAwO8UYwZpuUSFbW06x0CHksa
S9MAnjcv5ikl2dRFVyuG0/TXQZF0y3ER
=ACuG
-----END PGP SIGNATURE-----