OSEC

Neohapsis is currently accepting applications for employment. For more information, please visit our website www.neohapsis.com or email hr@neohapsis.com
[ GLSA 200908-04 ] Adobe products: Multiple vulnerabilities

From: Robert Buchholz (rbugentoo.org)
Date: Fri Aug 07 2009 - 07:01:32 CDT


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200908-04
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Adobe products: Multiple vulnerabilities
      Date: August 07, 2009
      Bugs: #278813, #278819
        ID: 200908-04

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities in Adobe Reader and Adobe Flash Player allow
for attacks including the remote execution of arbitrary code.

Background
==========

Adobe Flash Player is a closed-source playback software for Flash SWF
files. Adobe Reader is a closed-source PDF reader that plays Flash
content as well.

Affected packages
=================

    -------------------------------------------------------------------
     Package / Vulnerable / Unaffected
    -------------------------------------------------------------------
  1 www-plugins/adobe-flash < 10.0.32.18 >= 10.0.32.18
  2 app-text/acroread < 9.1.3 >= 9.1.3
    -------------------------------------------------------------------
     2 affected packages on all of their supported architectures.
    -------------------------------------------------------------------

Description
===========

Multiple vulnerabilities have been reported in Adobe Flash Player:

* lakehu of Tencent Security Center reported an unspecified memory
  corruption vulnerability (CVE-2009-1862).

* Mike Wroe reported an unspecified vulnerability, related to
  "privilege escalation" (CVE-2009-1863).

* An anonymous researcher through iDefense reported an unspecified
  heap-based buffer overflow (CVE-2009-1864).

* Chen Chen of Venustech reported an unspecified "null pointer
  vulnerability" (CVE-2009-1865).

* Chen Chen of Venustech reported an unspecified stack-based buffer
  overflow (CVE-2009-1866).

* Joran Benker reported that Adobe Flash Player facilitates
  "clickjacking" attacks (CVE-2009-1867).

* Jun Mao of iDefense reported a heap-based buffer overflow, related
  to URL parsing (CVE-2009-1868).

* Roee Hay of IBM Rational Application Security reported an
  unspecified integer overflow (CVE-2009-1869).

* Gareth Heyes and Microsoft Vulnerability Research reported that the
  sandbox in Adobe Flash Player allows for information disclosure, when
  "SWFs are saved to the hard drive" (CVE-2009-1870).

Impact
======

A remote attacker could entice a user to open a specially crafted PDF
file or web site containing Adobe Flash (SWF) contents, possibly
resulting in the execution of arbitrary code with the privileges of the
user running the application, or a Denial of Service (application
crash). Furthermore, a remote attacker could trick a user into clicking
a button on a dialog by supplying a specially crafted SWF file and
disclose sensitive information by exploiting a sandbox issue.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Adobe Flash Player users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot -v ">=www-plugins/adobe-flash-10.0.32.18"

All Adobe Reader users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-text/acroread-9.1.3"

References
==========

  [ 1 ] CVE-2009-1862
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1862
  [ 2 ] CVE-2009-1863
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1863
  [ 3 ] CVE-2009-1864
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1864
  [ 4 ] CVE-2009-1865
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1865
  [ 5 ] CVE-2009-1866
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1866
  [ 6 ] CVE-2009-1867
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1867
  [ 7 ] CVE-2009-1868
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1868
  [ 8 ] CVE-2009-1869
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1869
  [ 9 ] CVE-2009-1870
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1870

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200908-04.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
securitygentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2009 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.11 (GNU/Linux)

iQIcBAABCAAGBQJKfBeeAAoJECaaHo/OfoM5tyoQAKPxyLpzXmqYaz22W+q0V01K
4BX4drFh7FClYwydU7hJbzX1Z68JX25oUuqMZnZACHdFQbcpGo53b2pyUQ7MmfTe
IJPL+CllFqRTVB8KKIgvGu5h42OYLFD4TPUI95+DjtC/cfhhlFBopc3LHoq3P9dJ
+pW9UQiW47VOXzrCzMZ+le5ENAEgzFWcZHmy0GsNtSrGFPJZrXUTniEcaZJrxKRc
RT93nyL5bxj+1NMml21osUquw7BPi8D91y+JCFAjOjxefXgjGHnv7rXw/n/MY9hk
d9JPovMEyUB7tq/fiJoq1uddHzjuv2pHRqWl7zqKhWSI5Z0fy/lFW/3z/rYhNKn5
Al8mok/KE672hrZfbrMpMa8n2V7VcvXpVZvov83xQyceHxUqp6RDq7jipgJ5W426
EVuzesGQRvMFU7kdmPOFEn0UFB1Bt5nxQd2bM3752RDmo5OKKFnGNOo46LBNFbx6
xGiA4YCKeLFHLU1tIOeFPhgflppQQEROTB/YpZrHdAA/xrjscluW1YJXVOoz2Ccb
Ubdpymfydj9URvJhkmEDWHouh4OIzipPz3qQlpHiHRkPU5EuSwAdEgmkCHihFP7m
AwwoCwuyJLPO0vNmMscdhDzrmABrQq3+W0oTvzDfZT5FBuY3NL0VIRC+Bmr407+Y
QRdjvrAHSsX+lvry5csH
=XCve
-----END PGP SIGNATURE-----