OSEC

Neohapsis is currently accepting applications for employment. For more information, please visit our website www.neohapsis.com or email hr@neohapsis.com
 
Subject: Security Bulletins Digest
From: IT Resource Center (support_feedbackus-support.external.hp.com)
Date: Wed Oct 18 2000 - 06:17:37 CDT


                        HP Support Information Digests

===============================================================================
o IT Resource Center World Wide Web Service
   ---------------------------------------------------

   If you subscribed through the IT Resource Center and would
   like to be REMOVED from this mailing list, access the
   IT Resource Center on the World Wide Web at:

     http://us.itrc.hp.com/

   Login using your IT Resource Center User ID and Password.
   Then select Support Information Digests (located under
   Maintenance and Support). You may then unsubscribe from the
   appropriate digest.
===============================================================================


Digest Name: Daily Security Bulletins Digest
    Created: Wed Oct 18 3:00:02 PDT 2000

Table of Contents:

Document ID Title
--------------- -----------
HPSBUX0010-126 Sec. Vulnerability in Praesidium Web Proxy 1.0

The documents are listed below.
-------------------------------------------------------------------------------


Document ID: HPSBUX0010-126
Date Loaded: 20001017
      Title: Sec. Vulnerability in Praesidium Web Proxy 1.0

------------------------------------------------------------------------
   HEWLETT-PACKARD COMPANY SECURITY ADVISORY: #0126, 18 October '00
------------------------------------------------------------------------

The information in the following Security Advisory should be acted upon
as soon as possible. Hewlett-Packard Company will not be liable for any
consequences to any customer resulting from customer's failure to fully
implement instructions in this Security Advisory as soon as possible.

------------------------------------------------------------------------

PROBLEM: Apache 1.3.12 included in the HP Praesidium Web Proxy,
          contains a vulnerability.

PLATFORM: VVOS release 10.24 and 11.04 running VirtualVault 4.0,
          with HP Praesidium Proxy V1.0 only.

DAMAGE: Users can gain unauthorized file access if the proxy
          were to be used to serve static web pages that exist on
          the VirtualVault.

SOLUTION: Implementors of the HP Praesidium Proxy should be aware
          of the vulnerability and should examine their proxy
          configuration to determine if this vulnerability affects
          them. If so, they should reconfigure their web server as
          necessary.

AVAILABILITY: Not applicable.

------------------------------------------------------------------------
I.
  A. Background
     If the result of a RewriteRule is a filename that contains regular
     expression references, then an attacker may be able to access any
     file readable by the iwww user on the web server. Since the HP
     Praesidium Web proxy runs as user iwww in group www (and not root,
     as on a standard HP-UX system), the attacker would only have
     access to files readable by the iwww user, www group at SYSTEM
     INSIDE. The iwww user has no privileges or login access on
     the VirtualVault.

     Here are some example RewriteRule directives. The first two
     directives are vulnerable, the last one is not.

       RewriteRule /test/(.*) /usr/local/data/test-stuff/$1
       RewriteRule /more-icons/(.*) /icons/$1
       RewriteRule /go/(.*) http://www.otherserver.com/$1

  B. Fixing the problem
     Implementors of the HP Praesidium Proxy should be aware of the
     vulnerability and immediately examine their proxy configuration
     to determine if this vulnerability affects them. Reconfiguration
     of the web server should be done as necessary.

  C. Recommended solution
     * The HP Praesidium Proxy should NOT be used to serve static html
       content.
     * Static content should be served by the SYSTEM OUTSIDE iPlanet
       webserver.
     * RewriteRule directives should not rewrite to a reference from
       the "/" filesystem.

  D. To subscribe to automatically receive future NEW HP Security
     Bulletins from the HP IT Resource Center via electronic mail,
     do the following:

     Use your browser to get to the HP IT Resource Center page
     at:

       http://itrc.hp.com

      Under the Maintenance and Support Menu (Electronic Support Center):
      click on the "more..." link. Then -

      Use the 'Login' tab at the left side of the screen to login
      using your ID and password. Check with your system
      administrator to see if you have an existing login or use
      the "Register" button at the left to create a login. You will
      need to login in order to gain access to many areas of the ITRC.
      Remember to save the User ID assigned to you, and your password.

      Under the Maintenance and Support Menu, click on the "more..."
      link. Under the "Notifications" section (near the bottom of
      the page), select "Support Information Digests".

      To -subscribe- to future HP Security Bulletins or other
      Technical Digests, click the check box (in the left column)
      for the appropriate digest and then click the "Update
      Subscriptions" button at the bottom of the page.

      or

      To -review- bulletins already released, select the link
      (in the middle column) for the appropriate digest.

      To -gain access- to the Security Patch Matrix, select
      the link for "The Security Bulletins Archive". Once in
      the archive the third link is to our current Security
      Patch Matrix. Updated daily, this matrix categorizes security
      patches by platform/OS release, and by bulletin topic.

      The security patch matrix is also available via anonymous ftp:

      ftp.itrc.hp.com
      ~ftp/export/patches/hp-ux_patch_matrix"

      On the "Support Information Digest Main" page:
      click on the "HP Security Bulletin Archive".

   E. To report new security vulnerabilities, send email to

      security-alerthp.com

      Please encrypt any exploit information using the security-alert
      PGP key, available from your local key server, or by sending a
      message with a -subject- (not body) of 'get key' (no quotes) to
      security-alerthp.com.

      Permission is granted for copying and circulating this Advisory to
      Hewlett-Packard (HP) customers (or the Internet community) for the
      purpose of alerting them to problems, if and only if, the Advisory
      is not edited or changed in any way, is attributed to HP, and
      provided such reproduction and/or distribution is performed for
      non-commercial purposes.

      Any other use of this information is prohibited. HP is not liable
      for any misuse of this information by any third party.
________________________________________________________________________
-----End of Document ID: HPSBUX0010-126--------------------------------------