OSEC

Neohapsis is currently accepting applications for employment. For more information, please visit our website www.neohapsis.com or email hr@neohapsis.com
Re: pkg_add c.48.0 lib error on current

From: Sven Wolf (sven.wolffusion-zone.net)
Date: Tue Sep 16 2008 - 14:00:27 CDT


as written on ports...

the solution is "Either wait, or build from ports." Currently I build my
own packages from the ports. Because the offical snapshot packages
haven't been updated since august.

Best regards,
Sven

Stanislaus Hoppe wrote:
> Hello,
>
> I've tried to install the bash package
> (PKG_PATH=ftp://ftp.openbsd.org/pub/OpenBSD/snapshots/packages/i386/)
> on a -*current* system (4.4 GENERIC#1050 i386) but I get following error:
>
> pkg_add -v bash
> parsing bash-3.2.39
> Dependencies for bash-3.2.39 resolve to: *libiconv*-1.12, gettext-*0*.17
> (todo: *libiconv*-1.12,gettext-*0*.17)
> bash-3.2.39:parsing *libiconv*-1.12
> *Can*'t install *libiconv*-1.12: *lib* *not* *found* *c*.*48*.*0*
> *c*.*48*.*0*: partial match in /usr/*lib*: major=49, minor=*0* (bad major)
> bash-3.2.39:parsing gettext-*0*.17
> Dependencies for gettext-*0*.17 resolve to: *libiconv*-1.12 (todo:
> *libiconv*-1.12)
> bash-3.2.39:parsing *libiconv*-1.12
> *Can*'t install *libiconv*-1.12: *lib* *not* *found* *c*.*48*.*0*
> *c*.*48*.*0*: partial match in /usr/*lib*: major=49, minor=*0* (bad major)
> *Can*'t install gettext-*0*.17: *can*'t resolve *libiconv*-1.12
> *Can*'t install bash-3.2.39: *can*'t resolve *libiconv*-1.12,gettext-*0*.17
>
> Is there anything that I *can* do to fix this issue? In my opinion the
> *libiconv* package has to be packaged on a -*current* (#1050) system.
>
> Best regards,
> zm0