OSEC

Neohapsis is currently accepting applications for employment. For more information, please visit our website www.neohapsis.com or email hr@neohapsis.com
aucat bug in 4.8-beta/i386 ?

From: Gabriel Linder (linderjeuxvideo.com)
Date: Tue Aug 03 2010 - 02:18:08 CDT


Hi,

Mplayer hangs when playing music. After some search I found aucat was
exiting, leaving mplayer alone.

There are also a lot of cracks/pops in the audio stream (using
headphones), this happens with and without aucat running. Without aucat
the sound is total garbage after some time, this was previously caused
by interrupt storms but nothing this time...

vmstat -i :

interrupt total rate
irq0/clock 787366 199
irq0/ipi 1103407 279
irq80/inteldrm0 16597 4
irq96/em0 179316 45
irq81/uhci1 33708 8
irq83/ehci0 2 0
irq80/azalia0 95028 24
irq81/uhci3 10544 2
irq82/uhci4 29 0
irq84/ehci1 23 0
irq82/ahci0 30153 7
Total 2256173 570

aucat -d -d -d -d (normal use : aucat -l, takes some time to break) :

sio(default|): created
default: recording s16le,0:1,44100
default: playing s16le,0:1,44100
mix(play): newin, will use 11648
default: block size is 2912 frames, using 4 blocks
defaultdefault: rec=0:1 play=0:1 vol=32768
listen(/tmp/aucat-1000/softaudio0|): created
sock(sock|): created
sock/hel|rmsg|widl: HELLO message
sock/hel|rmsg|widl: hello from <mplayer>, proto = 1, ver 3
default: option found
device requested
ctl(ctl): new control name is mplayer0
ctl(ctl): overwritten slot 0
sock/hel|rmsg|widl: no read buffer to set volume yet
mplayer0(127)/off: changing volume to 127
mplayer0/ini|rmsg|widl: SETPAR message
mplayer0/ini|rmsg|widl: using 16bits, 2 bytes per sample
mplayer0/ini|rmsg|widl: using playback channels 0..1
mplayer0/ini|rmsg|widl: using 44100Hz sample rate, 2912 fr block size
mplayer0/ini|rmsg|widl: using 11648 buffer size
mplayer0: buffer size = 11648, play = s16le,0:1,44100
mplayer0/ini|rmsg|widl: GETPAR message
mplayer0/ini|rret|widl: RRET done
mplayer0/ini|rmsg|widl: GETPAR message
mplayer0/ini|rret|widl: RRET done
mplayer0/ini|rmsg|widl: GETPAR message
mplayer0/ini|rret|widl: RRET done
mplayer0/ini|rmsg|widl: START message
mplayer0/sta|rmsg|widl: allocating 11648/23296 fr buffers, rmax = 93184
mplayer0/run|rmsg|widl: attaching at 0
rsock(sock)->mix(play): setmaster: 32768/32768
syncing device, mix(play): todo = 0: lat = 0, sub(rec): lat = 0
rsock(sock)->mix(play): setting volume to 32768
starting device
sio(default|): started

(at this point aucat exits without being asked to)

sio(default|): busy loop, disconnecting
sio(default|): disconnected
sio(default|eh): eof
rsio(default): eof
rsio(default): terminating...
rsio(default): done
rsio(default)->sub(rec): eof requested
sub(rec): terminating...
sub(rec): free delayed
wsio(default): terminating...
wsio(default): done
mix(play)->wsio(default): hup requested
mix(play): hup
mix(play): terminating...
rsock(sock)->mix(play): hup requested
rsock(sock): hup
rsock(sock): terminating...
rsock(sock): done
mplayer0/ini|rmsg|widl: freeing buffers
wsock(sock): terminating...
wsock(sock): done
wsock(sock): freed
sock(sock|w): terminating...
sock(sock|w): destroyed
device released
rsock(sock): freed
mix(play): free delayed
sio(default|Reh): terminating...
wsio(default): free delayed
rsio(default): free delayed
sio(default|hZ): terminating...
sio(default|hZ): destroyed
sio(default|hZ): stopped
device disappeared
closing device
ctl(ctl): terminating...
ctl(ctl): done
ctl(ctl): free delayed
zomb(play): freed
zomb(default): freed
zomb(rec): freed
zomb(default): freed
zomb(ctl): freed
listen(/tmp/aucat-1000/softaudio0|): closing
listen(/tmp/aucat-1000/softaudio0|Z): terminating...
listen(/tmp/aucat-1000/softaudio0|Z): destroyed
nothing to do...

aucat -d -d -d -d -r 48000 -b 480 -z 240 (these parameters seems to
break aucat quickly) :

sio(default|): created
default: recording s16le,0:1,48000
default: playing s16le,0:1,48000
mix(play): newin, will use 448
default: block size is 224 frames, using 2 blocks
defaultdefault: rec=0:1 play=0:1 vol=32768
listen(/tmp/aucat-1000/softaudio0|): created
sock(sock|): created
sock/hel|rmsg|widl: HELLO message
sock/hel|rmsg|widl: hello from <mplayer>, proto = 1, ver 3
default: option found
device requested
ctl(ctl): new control name is mplayer0
ctl(ctl): overwritten slot 0
sock/hel|rmsg|widl: no read buffer to set volume yet
mplayer0(127)/off: changing volume to 127
mplayer0/ini|rmsg|widl: SETPAR message
mplayer0/ini|rmsg|widl: using 16bits, 2 bytes per sample
mplayer0/ini|rmsg|widl: using playback channels 0..1
mplayer0/ini|rmsg|widl: using 44100Hz sample rate, 206 fr block size
mplayer0/ini|rmsg|widl: using 11124 buffer size
mplayer0: buffer size = 11124, play = s16le,0:1,44100
mplayer0/ini|rmsg|widl: GETPAR message
mplayer0/ini|rret|widl: RRET done
mplayer0/ini|rmsg|widl: GETPAR message
mplayer0/ini|rret|widl: RRET done
mplayer0/ini|rmsg|widl: GETPAR message
mplayer0/ini|rret|widl: RRET done
mplayer0/ini|rmsg|widl: START message
mplayer0/sta|rmsg|widl: allocating 11124/11536 fr buffers, rmax = 46144
mplayer0/run|rmsg|widl: attaching at 0
resamp(sock): new 206/224
resamp(sock)->mix(play): setmaster: 32768/32768
syncing device, mix(play): todo = 0: lat = 0, sub(rec): lat = 0
rsock(sock)->resamp(sock): setting volume to 32768
starting device
sio(default|): started

(after some time)

default: read 896 bytes in 54874us
sio(default|): busy loop, disconnecting
sio(default|): disconnected
sio(default|eh): eof
rsio(default): eof
rsio(default): terminating...
rsio(default): done
rsio(default)->sub(rec): eof requested
sub(rec): terminating...
sub(rec): free delayed
wsio(default): terminating...
wsio(default): done
mix(play)->wsio(default): hup requested
mix(play): hup
mix(play): terminating...
resamp(sock)->mix(play): hup requested
resamp(sock)->none: hup: lost 224 bytes
resamp(sock): hup
resamp(sock): terminating...
rsock(sock)->resamp(sock): hup requested
rsock(sock)->none: hup: lost 10506 bytes
rsock(sock): hup
rsock(sock): terminating...
rsock(sock): done
mplayer0/ini|rmsg|widl: freeing buffers
wsock(sock): terminating...
wsock(sock): done
wsock(sock): freed
sock(sock|w): terminating...
sock(sock|w): destroyed
device released
rsock(sock): freed
resamp(sock): freed
mix(play): free delayed
sio(default|Reh): terminating...
wsio(default): free delayed
rsio(default): free delayed
sio(default|hZ): terminating...
sio(default|hZ): destroyed
sio(default|hZ): stopped
device disappeared
closing device
ctl(ctl): terminating...
ctl(ctl): done
ctl(ctl): free delayed
zomb(play): freed
zomb(default): freed
zomb(rec): freed
zomb(default): freed
zomb(ctl): freed
listen(/tmp/aucat-1000/softaudio0|): closing
listen(/tmp/aucat-1000/softaudio0|Z): terminating...
listen(/tmp/aucat-1000/softaudio0|Z): destroyed
nothing to do...

dmesg :

OpenBSD 4.8-beta (GENERIC.MP) #293: Sun Aug 1 22:21:46 MDT 2010
    deraadti386.openbsd.org:/usr/src/sys/arch/i386/compile/GENERIC.MP
RTC BIOS diagnostic error 11<memory_size>
cpu0: Intel(R) Core(TM)2 Duo CPU E8200 2.66GHz ("GenuineIntel" 686-class) 2.67 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1
real mem = 2101956608 (2004MB)
avail mem = 2057592832 (1962MB)
mainbus0 at root
bios0 at mainbus0: AT/286+ BIOS, date 03/11/08, BIOS32 rev. 0 0xffea0, SMBIOS rev. 2.5 0xf0450 (80 entries)
bios0: vendor Dell Inc. version "A09" date 03/11/2008
bios0: Dell Inc. OptiPlex 755
acpi0 at bios0: rev 2
acpi0: tables DSDT FACP SSDT APIC BOOT ASF! MCFG HPET ____ SLIC
acpi0: wakeup devices VBTN(S4) PCI0(S5) PCI4(S5) PCI2(S5) PCI3(S5) PCI1(S5) PCI5(S5) PCI6(S5) MOU_(S3) USB0(S3) USB1(S3) USB2(S3) USB3(S3) USB4(S3) USB5(S3)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: apic clock running at 332MHz
cpu1 at mainbus0: apid 1 (application processor)
cpu1: Intel(R) Core(TM)2 Duo CPU E8200 2.66GHz ("GenuineIntel" 686-class) 2.66 GHz
cpu1: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1
ioapic0 at mainbus0: apid 8 pa 0xfec00000, version 20, 24 pins
ioapic0: misconfigured as apic 0, remapped to apid 8
acpihpet0 at acpi0: 14318179 Hz
acpiprt0 at acpi0: bus 2 (PCI4)
acpiprt1 at acpi0: bus 1 (PCI2)
acpiprt2 at acpi0: bus -1 (PCI3)
acpiprt3 at acpi0: bus -1 (PCI1)
acpiprt4 at acpi0: bus -1 (PCI5)
acpiprt5 at acpi0: bus -1 (PCI6)
acpiprt6 at acpi0: bus 0 (PCI0)
acpicpu0 at acpi0
acpicpu1 at acpi0
acpibtn0 at acpi0: VBTN
bios0: ROM list: 0xc0000/0xb800! 0xcb800/0x2000! 0xcd800/0x2800!
cpu0: unknown Enhanced SpeedStep CPU, msr 0x0612081f0600081f
cpu0: using only highest and lowest power states
cpu0: Enhanced SpeedStep 2660 MHz: speeds: 2667, 2000 MHz
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 "Intel 82Q35 Host" rev 0x02
vga1 at pci0 dev 2 function 0 "Intel 82Q35 Video" rev 0x02
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
intagp0 at vga1
agp0 at intagp0: aperture at 0xd0000000, size 0x10000000
inteldrm0 at vga1: apic 8 int 16 (irq 11)
drm0 at inteldrm0
"Intel 82Q35 Video" rev 0x02 at pci0 dev 2 function 1 not configured
"Intel 82Q35 HECI" rev 0x02 at pci0 dev 3 function 0 not configured
pciide0 at pci0 dev 3 function 2 "Intel 82Q35 PT IDER" rev 0x02: DMA (unsupported), channel 0 wired to native-PCI, channel 1 wired to native-PCI
pciide0: using apic 8 int 18 (irq 9) for native-PCI interrupt
pciide0: channel 0 ignored (not responding; disabled or no drives?)
pciide0: channel 1 ignored (not responding; disabled or no drives?)
"Intel 82Q35 KT" rev 0x02 at pci0 dev 3 function 3 not configured
em0 at pci0 dev 25 function 0 "Intel ICH9 IGP AMT" rev 0x02: apic 8 int 21 (irq 3), address 00:1e:4f:c5:11:9f
uhci0 at pci0 dev 26 function 0 "Intel 82801I USB" rev 0x02: apic 8 int 16 (irq 11)
uhci1 at pci0 dev 26 function 1 "Intel 82801I USB" rev 0x02: apic 8 int 17 (irq 5)
ehci0 at pci0 dev 26 function 7 "Intel 82801I USB" rev 0x02: apic 8 int 22 (irq 5)
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
azalia0 at pci0 dev 27 function 0 "Intel 82801I HD Audio" rev 0x02: apic 8 int 16 (irq 11)
azalia0: codecs: Analog Devices AD1984
audio0 at azalia0
ppb0 at pci0 dev 28 function 0 "Intel 82801I PCIE" rev 0x02: apic 8 int 16 (irq 11)
pci1 at ppb0 bus 1
uhci2 at pci0 dev 29 function 0 "Intel 82801I USB" rev 0x02: apic 8 int 23 (irq 10)
uhci3 at pci0 dev 29 function 1 "Intel 82801I USB" rev 0x02: apic 8 int 17 (irq 5)
uhci4 at pci0 dev 29 function 2 "Intel 82801I USB" rev 0x02: apic 8 int 18 (irq 9)
ehci1 at pci0 dev 29 function 7 "Intel 82801I USB" rev 0x02: apic 8 int 23 (irq 10)
usb1 at ehci1: USB revision 2.0
uhub1 at usb1 "Intel EHCI root hub" rev 2.00/1.00 addr 1
ppb1 at pci0 dev 30 function 0 "Intel 82801BA Hub-to-PCI" rev 0x92
pci2 at ppb1 bus 2
ichpcib0 at pci0 dev 31 function 0 "Intel 82801IO LPC" rev 0x02: PM disabled
ahci0 at pci0 dev 31 function 2 "Intel 82801I AHCI" rev 0x02: apic 8 int 18 (irq 9), AHCI 1.2
ahci0: PHY offline on port 2
ahci0: PHY offline on port 3
ahci0: PHY offline on port 5
scsibus0 at ahci0: 32 targets
sd0 at scsibus0 targ 0 lun 0: <ATA, ST3250310AS, 3.AD> SCSI3 0/direct fixed
sd0: 238418MB, 512 bytes/sec, 488281250 sec total
cd0 at scsibus0 targ 1 lun 0: <TSSTcorp, DVD+-RW TS-H653B, D300> ATAPI 5/cdrom removable
ichiic0 at pci0 dev 31 function 3 "Intel 82801I SMBus" rev 0x02: apic 8 int 18 (irq 9)
iic0 at ichiic0
spdmem0 at iic0 addr 0x50: 1GB DDR2 SDRAM non-parity PC2-5300CL5
spdmem1 at iic0 addr 0x52: 1GB DDR2 SDRAM non-parity PC2-5300CL5
usb2 at uhci0: USB revision 1.0
uhub2 at usb2 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb3 at uhci1: USB revision 1.0
uhub3 at usb3 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb4 at uhci2: USB revision 1.0
uhub4 at usb4 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb5 at uhci3: USB revision 1.0
uhub5 at usb5 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb6 at uhci4: USB revision 1.0
uhub6 at usb6 "Intel UHCI root hub" rev 1.00/1.00 addr 1
isa0 at ichpcib0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
mtrr: Pentium Pro MTRR support
uhub7 at uhub1 port 6 "Standard Microsystems product 0x2514" rev 2.00/0.00 addr 2
uhidev0 at uhub3 port 1 configuration 1 interface 0 "Logitech Optical USB Mouse" rev 2.00/3.40 addr 2
uhidev0: iclass 3/1
ums0 at uhidev0: 3 buttons, Z dir
wsmouse0 at ums0 mux 0
ugen0 at uhub6 port 1 "American Power Conversion Smart-UPS 750 FW:651.13.I USB FW:7.3" rev 1.10/0.06 addr 2
uhidev1 at uhub5 port 2 configuration 1 interface 0 "Dell Dell USB Keyboard" rev 1.10/3.52 addr 2
uhidev1: iclass 3/1
ukbd0 at uhidev1: 8 modifier keys, 6 key codes
wskbd0 at ukbd0: console keyboard, using wsdisplay0
softraid0 at root
root on sd0a swap on sd0b dump on sd0b