OSEC

Neohapsis is currently accepting applications for employment. For more information, please visit our website www.neohapsis.com or email hr@neohapsis.com
Re: Slow disk IO HP DL120 G5 with LSI1068E

From: Marco Peereboom (slashpeereboom.us)
Date: Tue Aug 31 2010 - 11:00:26 CDT


Your disks have write cache disabled. I started on a diff but hit a
roadblock and didn't get back to figuring this out. Currently the only
way to "fix" this is to undo the raid volume and let the actual physical
disks show up. Then enable write cache on them using scsi. Not really
something for the faint hearted. At some point I'll go spend some time
to figure this out but not anytime soon :-(

On Tue, Aug 31, 2010 at 06:52:44PM +0300, Evgeniy Sudyr wrote:
> I have troubles with on OpenBSD 4.7 with HP DL 120 G5
>
> Actually I'm trying to unpack src.tar.gz and see that it's very slow.
>
> There is my systat during unpacking and dmesg for the server
>
> systat
>
> 2 users Load 2.77 2.48 2.17 Tue Aug 31 19:46:02 2010
>
> memory totals (in KB) PAGING SWAPPING Interrupts
> real virtual free in out in out 568 total
> Active 13212 13212 3281736 ops 400 clock
> All 410024 410024 7342468 pages 79 ipi
> 88 mpi0
> Proc:r d s w Csw Trp Sys Int Sof Flt forks 1 em0
> 2 6 164 1 258 89 100 9 fkppw uhci3
> fksvm ehci1
> 0.0%Int 0.1%Sys 0.2%Usr 0.0%Nic 99.7%Idle pwait
> | | | | | | | | | | | relck
> rlkok
> noram
> Namei Sys-cache Proc-cache No-cache ndcpy
> Calls hits % hits % miss % fltcp
> 881 742 84 4 0 135 15 zfod
> cow
> Disks sd0 30764 fmin
> seeks 41018 ftarg
> xfers 88 itarg
> speed 761K 49 wired
> sec 1.0 pdfre
> pdscn
> pzidle
> 15 kmapent
>
> dmesg
>
> OpenBSD 4.7 (GENERIC.MP) #130: Wed Mar 17 20:48:50 MDT 2010
> deraadtamd64.openbsd.org:/usr/src/sys/arch/amd64/compile/GENERIC.MP
> real mem = 3889758208 (3709MB)
> avail mem = 3780005888 (3604MB)
> mainbus0 at root
> bios0 at mainbus0: SMBIOS rev. 2.5 0xdc010 (43 entries)
> bios0: vendor HP version "O22" date 10/09/2009
> bios0: HP ProLiant DL120 G5
> acpi0 at bios0: rev 2
> acpi0: tables DSDT FACP SPMI EINJ HEST BERT SSDT ERST MCFG APIC BOOT
> SPCR SSDT SSDT SSDT
> acpi0: wakeup devices USB4(S3) USB5(S3) USB7(S3) ESB2(S4) EXP1(S4)
> EXP2(S4) EXP3(S4) EXP4(S4) EXP5(S4) EXP6(S4) USB1(S3) USB2(S3)
> USB3(S3) USB6(S3) ESB1(S3) PCIB(S3) PWRB(S3)
> acpitimer0 at acpi0: 3579545 Hz, 24 bits
> acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
> cpu0 at mainbus0: apid 0 (boot processor)
> cpu0: Intel(R) Xeon(R) CPU X3210 2.13GHz, 2133.65 MHz
> cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,DS-CPL,VMX,EST,TM2,CX16,xTPR,NXE,LONG
> cpu0: 4MB 64b/line 16-way L2 cache
> cpu0: apic clock running at 266MHz
> cpu1 at mainbus0: apid 1 (application processor)
> cpu1: Intel(R) Xeon(R) CPU X3210 2.13GHz, 2133.33 MHz
> cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,DS-CPL,VMX,EST,TM2,CX16,xTPR,NXE,LONG
> cpu1: 4MB 64b/line 16-way L2 cache
> cpu2 at mainbus0: apid 2 (application processor)
> cpu2: Intel(R) Xeon(R) CPU X3210 2.13GHz, 2133.33 MHz
> cpu2: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,DS-CPL,VMX,EST,TM2,CX16,xTPR,NXE,LONG
> cpu2: 4MB 64b/line 16-way L2 cache
> cpu3 at mainbus0: apid 3 (application processor)
> cpu3: Intel(R) Xeon(R) CPU X3210 2.13GHz, 2133.33 MHz
> cpu3: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,DS-CPL,VMX,EST,TM2,CX16,xTPR,NXE,LONG
> cpu3: 4MB 64b/line 16-way L2 cache
> ioapic0 at mainbus0: apid 4 pa 0xfec00000, version 20, 24 pins
> acpiprt0 at acpi0: bus 0 (PCI0)
> acpiprt1 at acpi0: bus 1 (PEG1)
> acpiprt2 at acpi0: bus -1 (PEG2)
> acpiprt3 at acpi0: bus 5 (EXP1)
> acpiprt4 at acpi0: bus -1 (EXP2)
> acpiprt5 at acpi0: bus -1 (EXP3)
> acpiprt6 at acpi0: bus -1 (EXP4)
> acpiprt7 at acpi0: bus 13 (EXP5)
> acpiprt8 at acpi0: bus 14 (EXP6)
> acpiprt9 at acpi0: bus 17 (PCIB)
> acpicpu0 at acpi0: C3, PSS
> acpicpu1 at acpi0: C3, PSS
> acpicpu2 at acpi0: C3, PSS
> acpicpu3 at acpi0: C3, PSS
> acpibtn0 at acpi0: PWRB
> ipmi at mainbus0 not configured
> cpu0: Enhanced SpeedStep 2133 MHz: speeds: 2133, 1600 MHz
> pci0 at mainbus0 bus 0
> pchb0 at pci0 dev 0 function 0 "Intel 3200/3210 Host" rev 0x01
> ppb0 at pci0 dev 1 function 0 "Intel 3200/3210 PCIE" rev 0x01: apic 4
> int 16 (irq 5)
> pci1 at ppb0 bus 1
> mpi0 at pci1 dev 0 function 0 "Symbios Logic SAS1068E" rev 0x08: apic
> 4 int 16 (irq 5)
> scsibus0 at mpi0: 112 targets
> sd0 at scsibus0 targ 1 lun 0: <LSILOGIC, Logical Volume, 3000> SCSI2
> 0/direct fixed
> sd0: 237464MB, 512 bytes/sec, 486326272 sec total
> uhci0 at pci0 dev 26 function 0 "Intel 82801I USB" rev 0x02: apic 4
> int 16 (irq 5)
> uhci1 at pci0 dev 26 function 1 "Intel 82801I USB" rev 0x02: apic 4
> int 17 (irq 10)
> uhci2 at pci0 dev 26 function 2 "Intel 82801I USB" rev 0x02: apic 4
> int 18 (irq 3)
> ehci0 at pci0 dev 26 function 7 "Intel 82801I USB" rev 0x02: apic 4
> int 18 (irq 3)
> usb0 at ehci0: USB revision 2.0
> uhub0 at usb0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
> ppb1 at pci0 dev 28 function 0 "Intel 82801I PCIE" rev 0x02: apic 4
> int 16 (irq 5)
> pci2 at ppb1 bus 5
> em0 at pci2 dev 0 function 0 "Intel PRO/1000 PT (82572EI)" rev 0x06:
> apic 4 int 16 (irq 5), address 00:18:71:ec:02:9d
> ppb2 at pci0 dev 28 function 4 "Intel 82801I PCIE" rev 0x02: apic 4
> int 16 (irq 5)
> pci3 at ppb2 bus 13
> vga1 at pci3 dev 0 function 0 "Matrox MGA G200e (ServerEngines)" rev 0x02
> wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
> wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
> ppb3 at pci0 dev 28 function 5 "Intel 82801I PCIE" rev 0x02: apic 4
> int 17 (irq 10)
> pci4 at ppb3 bus 14
> bge0 at pci4 dev 0 function 0 "Broadcom BCM5722" rev 0x00, BCM5755 C0
> (0xa200): apic 4 int 17 (irq 10), address 00:23:7d:aa:06:61
> brgphy0 at bge0 phy 1: BCM5722 10/100/1000baseT PHY, rev. 0
> uhci3 at pci0 dev 29 function 0 "Intel 82801I USB" rev 0x02: apic 4
> int 16 (irq 5)
> uhci4 at pci0 dev 29 function 1 "Intel 82801I USB" rev 0x02: apic 4
> int 17 (irq 10)
> uhci5 at pci0 dev 29 function 2 "Intel 82801I USB" rev 0x02: apic 4
> int 18 (irq 3)
> ehci1 at pci0 dev 29 function 7 "Intel 82801I USB" rev 0x02: apic 4
> int 16 (irq 5)
> usb1 at ehci1: USB revision 2.0
> uhub1 at usb1 "Intel EHCI root hub" rev 2.00/1.00 addr 1
> ppb4 at pci0 dev 30 function 0 "Intel 82801BA Hub-to-PCI" rev 0x92
> pci5 at ppb4 bus 17
> pcib0 at pci0 dev 31 function 0 "Intel 82801IR LPC" rev 0x02
> pciide0 at pci0 dev 31 function 2 "Intel 82801I SATA" rev 0x02: DMA,
> channel 0 configured to native-PCI, channel 1 configured to native-PCI
> pciide0: using apic 4 int 17 (irq 10) for native-PCI interrupt
> ichiic0 at pci0 dev 31 function 3 "Intel 82801I SMBus" rev 0x02: apic
> 4 int 17 (irq 10)
> iic0 at ichiic0
> spdmem0 at iic0 addr 0x50: 2GB DDR2 SDRAM ECC PC2-6400CL5
> spdmem1 at iic0 addr 0x51: 2GB DDR2 SDRAM ECC PC2-6400CL5
> spdmem2 at iic0 addr 0x52: 2GB DDR2 SDRAM ECC PC2-6400CL5
> spdmem3 at iic0 addr 0x53: 2GB DDR2 SDRAM ECC PC2-6400CL5
> pciide1 at pci0 dev 31 function 5 "Intel 82801I SATA" rev 0x02: DMA,
> channel 0 wired to native-PCI, channel 1 wired to native-PCI
> pciide1: using apic 4 int 18 (irq 3) for native-PCI interrupt
> usb2 at uhci0: USB revision 1.0
> uhub2 at usb2 "Intel UHCI root hub" rev 1.00/1.00 addr 1
> usb3 at uhci1: USB revision 1.0
> uhub3 at usb3 "Intel UHCI root hub" rev 1.00/1.00 addr 1
> usb4 at uhci2: USB revision 1.0
> uhub4 at usb4 "Intel UHCI root hub" rev 1.00/1.00 addr 1
> usb5 at uhci3: USB revision 1.0
> uhub5 at usb5 "Intel UHCI root hub" rev 1.00/1.00 addr 1
> usb6 at uhci4: USB revision 1.0
> uhub6 at usb6 "Intel UHCI root hub" rev 1.00/1.00 addr 1
> usb7 at uhci5: USB revision 1.0
> uhub7 at usb7 "Intel UHCI root hub" rev 1.00/1.00 addr 1
> isa0 at pcib0
> isadma0 at isa0
> com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
> pckbc0 at isa0 port 0x60/5
> pcppi0 at isa0 port 0x61
> midi0 at pcppi0: <PC speaker>
> spkr0 at pcppi0
> mtrr: Pentium Pro MTRR support
> uhidev0 at uhub5 port 2 configuration 1 interface 0 "ServerEngines SE
> USB Device" rev 1.10/0.01 addr 2
> uhidev0: iclass 3/1
> ukbd0 at uhidev0: 8 modifier keys, 6 key codes
> wskbd0 at ukbd0: console keyboard, using wsdisplay0
> uhidev1 at uhub5 port 2 configuration 1 interface 1 "ServerEngines SE
> USB Device" rev 1.10/0.01 addr 2
> uhidev1: iclass 3/1
> ums0 at uhidev1: 8 buttons, Z dir
> wsmouse0 at ums0 mux 0
> vscsi0 at root
> scsibus1 at vscsi0: 256 targets
> softraid0 at root
> root on sd0a swap on sd0b dump on sd0b
>
>
> # dd if=/dev/zero of=/tmp/tmp bs=1 count=10000000
> 10000000+0 records in
> 10000000+0 records out
> 10000000 bytes transferred in 14.213 secs (703548 bytes/sec)
>
>
> I tried to disable acpi, but that not helped. Results are same.
>
> This is about driver problems or something else ?
>
> --
> With regards,
> Eugene Sudyr