OSEC

Neohapsis is currently accepting applications for employment. For more information, please visit our website www.neohapsis.com or email hr@neohapsis.com
 
Subject: Re: a connection take so long!
From: Lutz Jaenicke (Lutz.Jaenickeaet.TU-Cottbus.DE)
Date: Wed May 03 2000 - 10:39:56 CDT


On Wed, May 03, 2000 at 03:56:58PM +0200, Thomas Braun wrote:
> my mail server running debian and on it the frozen version postfix
> 0.0.19991231pl05-1
>
>
> my problem is if i connect with telnet on port 25 it take about 5
> seconds to get the postfix connection (in netscape the same ) i have
> edited the master.cf to this and now it is faster
> smtp inet n - - 3 - smtpd
>
> but now i get allways messages in the syslog like this
> May 3 15:57:02 socrates postfix/smtpd[5205]: connect from
> socrates[127.0.0.1]
> May 3 15:57:02 socrates postfix/smtpd[5205]: lost connection after
> CONNECT from
> socrates[127.0.0.1]
>
> can anybody help me?

Ralf Hildebrandt already commented your change to master.cf.

Now, let's find out why you do have a delay of 5s on startup...
(I don't have any delay on startup, and I don't see any reason
why should have one; I have both HP-UX and Linux versions running).

Whenever an smtp connection is opened, postfix does several hostname and
IP address checks. I would suspect those, especially since you get
...socrates[127.0.0.1]...
127.0.0.1 == localhost
socrates.XXXXXXXXX.de == 192.168.?.? (?, since I don't know better)
But socrates != 127.0.0.1

What kind of setup are you using? DNS, NIS, /etc/hosts, all? Do you have a
dialup connection and/or a local DNS server?

Best regards,
        Lutz

-- 
Lutz Jaenicke                             Lutz.Jaenickeaet.TU-Cottbus.DE
BTU Cottbus               http://www.aet.TU-Cottbus.DE/personen/jaenicke/
Lehrstuhl Allgemeine Elektrotechnik                  Tel. +49 355 69-4129
Universitaetsplatz 3-4, D-03044 Cottbus              Fax. +49 355 69-4153