OSEC

Neohapsis is currently accepting applications for employment. For more information, please visit our website www.neohapsis.com or email hr@neohapsis.com
Re: Strange problem in SMTP communication

From: Emanuele Gallo (manugal83gmail.com)
Date: Sun Apr 11 2010 - 13:20:25 CDT


Sorry, can you tell me how can I send binary attachments in this mailing
list? Thanks.

Il 11/04/2010 15:11, Wietse Venema ha scritto:
> Emanuele Gallo:
>
>> Hi!
>>
>> I've developed a RFC821-compliant mail server. I want to make it clear
>> first that my server works well either with a mail client, as
>> Thunderbird, and with telnet session. I've configured Postfix to
>> communicate with my server modifying main.cf in this way:
>>
>> relayhost = [myMailServer.localhost]
>> smtp_sasl_auth_enable = no
>> smtp_use_tls = no
>> disable_dns_lookups=yes
>> smtp_never_send_ehlo = yes
>> Then I try to send an email through mail command:
>>
>> manugalmanugal-desktop:~$ mail -v -s "Subject"
>> ManugalmyMailServer.localhost
>> Hello world!
>> .
>> EOT
>> Mail Delivery Status Report will be mailed to<manugal>.
>> manugalmanugal-desktop:~$
>> But mail doesn't arrive. Analyzing mail.log I've discovered that Postfix
>> doesn't receive 250 response (but receive a blank line). Nevertheless,
>> if I debug my server with gdb, I can see that it sends the string "250
>> OK\r\n". To do an attempt, then I've tried to send, as a response,
>> "\r\n250 OK\r\n" (so a 250 response code preceded by a CRLF). And now
>> response seems arrive at the other side. Look at mail.log:
>>
> If you want help, capture a recording of a FAILED SMTP session with:
>
> # tcpdump -w /file/name -s 0 host your.ip.adress and port 25
>
> as a binary attachment, after checking that this file contains no
> private email.
>
> Wietse
>
>