OSEC

Neohapsis is currently accepting applications for employment. For more information, please visit our website www.neohapsis.com or email hr@neohapsis.com
Re: Upgrade 2.5.4

From: Linux Addict (linuxaddict7gmail.com)
Date: Tue Nov 02 2010 - 12:21:03 CDT


On Wed, Oct 20, 2010 at 3:21 PM, Linux Addict <linuxaddict7gmail.com>wrote:

>
> On Tue, Oct 19, 2010 at 3:37 PM, fakesshfakessh.eu <fakesshfakessh.eu>wrote:
>
>> -----BEGIN PGP SIGNED MESSAGE-----
>> Hash: SHA1
>>
>> Le 19.10.2010 19:42, Victor Duchovni a écrit :
>> > On Tue, Oct 19, 2010 at 12:17:23PM -0400, Linux Addict wrote:
>> >
>> >> Hello, I am running postfix 2.5.4 and would like to upgrade it to
>> latest
>> >> stable 2.7.0. What is the best way upgrade? Do a clean install and port
>> the
>> >> settings to newer version? Any help is appreciated.
>> >
>> > No. Do an upgrade. If installing from source:
>> >
>> > Read the RELEASE_NOTES file for 2.6 and 2.7, then:
>> >
>> > % make
>> > % su root
>> > # postfix stop
>> > # make upgrade
>> > # postfix start
>> >
>> > If installing from a well constructed package:
>> >
>> > Read the RELEASE_NOTES file for 2.6 and 2.7, then:
>> >
>> > # postfix stop
>> > # some-command-to-install-updated-package
>> > # postfix start
>> >
>> > In either case, save the updated main.cf and master.cf files that
>> > are automatically upgraded as part of the install process.
>> >
>> > If the package is not well constructed:
>> >
>> > Read the RELEASE_NOTES file for 2.6 and 2.7, then:
>> >
>> > # postfix stop
>> >
>> > # mkdir -p /etc/postfix/cfsavedir
>> > # cp /etc/postfix/main.cf /etc/postfix/master.cf \
>> > /etc/postfix/cfsavedir/
>> >
>> > # some-command-to-install-updated-poorly-constructed-package
>> >
>> > # cp /etc/postfix/cfsavedir/main.cf /etc/postfix/cfsavedir/
>> master.cf \
>> > /etc/postfix/
>> > # postfix set-permissions upgrade-configuration
>> >
>> > # postfix start
>> >
>> > A package is not well contstructed if it fails to preserve and upgrade
>> > your existing main.cf and master.cf files.
>> >
>>
>>
> Thanks Victor. Reading from 2.6 releasing notes, it looks like postfix
> changed how multiple instances are handled. I am going to test on sandbox.
>

Sorry about beating the dead horse, but just came to know that there are few
2.2 postfix instances which needs to upgraded to 2.7 as well. Does upgrade
stands true for 2.2 to 2.7 or install a clean 2.7 and just port the postconf
-n will suffice?

thanks again.